The ZhongYi Lens Turbo ii is what’s referred to as a focal reducer, which is essentially an adapter that not only allows one to mount vintage lenses onto a modern camera bodies, but also maintains the original range even on an crop sensor. I’m not going to get into all that technical stuff here, primarily because I don’t really understand nor do I care. I just want it to work.

Which is where the problem arose. I have three Canon FD lenses but only one of them would mount to the Lens Turbo (LT).

  • Canon 28mm f2.8 = won’t mount, aperture seems to work
  • Canon 50mm f1.8 = won’t mount, aperture stuck wide open (separate issue)
  • Vivitar 80-200 f3.5-5.6 = mounts fine, everything seems to work

Let me start off by acknowledging that I am not a camera person, nor am I an engineer (much to the disappointment of my father), but I’m stubborn and really wanted to get this system to work so here we go.

Initial attempts to mount the 28 to the LT were pretty frustrating. The instructions state that you line up red-red, rotate red-yellow, then rotate back past the red to secure. It only sort of worked and that last rotation wouldn’t go nearly far enough.

The issue seemed to directly involve the aperture signal pin. More precisely, the internal part of the LT seemed to be too shallow for the aperture signal pin to fit within, which prevented the lens from fully engaging with the LT.

 

You can see some scratching inside the LT from the several dozen attempts made.

My solution: shave off a little bit of the pin so that it would clear.  Using a rotary tool, I began grinding off a very small amount and then retried, repeating until it worked. I probably had to remove about 1.25mm of the pin before it would fit and rotate without issue.

 

It now fastens together perfectly, aperture is controlled by the on-lens ring, and all is good.

Zhongyi Lens Turbo ii Compatibility and Mounting Problems